Browse Source

fix: make update script compatible with both MacOS and Linux

Fix sed inplace option to run with both GNU sed and MacOS sed.

Previous use of sed may have only worked on MacOS.

See #52
master
Cyrille 2 years ago
committed by George
parent
commit
de3aa13f6f
  1. 2
      update_academic.sh

2
update_academic.sh

@ -31,7 +31,7 @@ function do_update () {
version=$(sed -n 's/^min_version = //p' themes/academic/theme.toml | tr -d '"')
version="${version}.0"
echo "Set Netlify Hugo version to v${version}"
sed -i '' -e "s/HUGO_VERSION = .*/HUGO_VERSION = \"$version\"/g" ./netlify.toml
sed -i.bak -e "s/HUGO_VERSION = .*/HUGO_VERSION = \"$version\"/g" ./netlify.toml && rm -f ./netlify.toml.bak
fi
echo

Loading…
Cancel
Save